User Requirements for Moodle
Posted by SHeD Staff, Last modified by SHeD Staff 3 on 30 August 2018 09:35 AM

Description: Computer and software requirements to access Moodle
Tags: Moodle, requirements, computer, skills, course, support, help


BASIC COMPUTER SKILLS

While any student can use Moodle, it is recommended that you have the following Computer Skills before diving in:

  • Basic Computer Skills
  • Knowledge of how to use mouse, keyboard, Hotkeys
  • Experience navigating the Internet and using an Internet browser
  • Basic knowledge of formatting and using a word processor (such as Microsoft Word)
  • Comfort working with multiple windows/tabs
  • Web Netiquette - students must know the do's and don'ts of online class communication

BASIC COMPUTER/SOFTWARE REQUIREMENTS

Computer Requirements

For using Moodle, you must have one of the following web browsers installed on your computer. We recommend Mozilla Firefox for both PC and Mac users. Internet Explorer is less reliable than Firefox.

  • Internet connection
  • Current web browser

Web Browsers

  • Mozilla Firefox (version 25.0 or later) 
  • Internet Explorer (version 9 or later)
  • Google Chrome (version 30.0 or later)
  • Safari (version 6 or later)
  • Opera (version 9)

Additional Requirements

Some Courses May Also Require



For further help, click on Live Help, leave a ticket, or contact:
Student Help Desk
shed@lanecc.edu
(541) 463-3333

(5 vote(s))
Helpful
Not helpful